We’ve identified an issue with our Sandbox service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Apr 15, 2024 - 17:53 IDT
Identified
We confirm there is a problem with our Sandbox service, and we’re working to resolve it.
Posted Apr 15, 2024 - 17:52 IDT
This incident affected: Sandbox (Sandbox).