We’ve identified an issue with our Workforce planning service
Incident Report for HiBob
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 19:23 IDT
Identified
We confirm there is a problem with our Workforce planning service, and we’re working to resolve it.
Posted Sep 05, 2024 - 15:47 IDT
This incident affected: Workforce planning (Workforce planning).