We’ve identified an issue with our Talent service

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted Nov 27, 2023 - 11:09 IST

Identified

We confirm there is a problem with our Talent service, and we’re working to resolve it.
Posted Nov 27, 2023 - 11:08 IST
This incident affected: Talent (Surveys).