Flows - Only Admins can create New Hire

Incident Report for HiBob

Resolved

The issue affecting the New Hire flow, where only admins could create new hires, has been resolved.
Posted Aug 19, 2026 - 11:32 IDT

Monitoring

We’ve identified the root cause and fixed the issue affecting the New Hire flow. We are monitoring the results.
Posted Aug 19, 2026 - 11:02 IDT

Investigating

We’ve identified an issue with the New Hire flow where only admins can create new hires.
Posted Aug 19, 2026 - 10:44 IDT
This incident affected: Core HR (Flows).