We’ve identified an issue with our Compensation service

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted Feb 10, 2025 - 12:17 IST

Identified

We confirm there is a problem with our Compensation service, and we’re working to resolve it.
Posted Feb 10, 2025 - 11:59 IST
This incident affected: Compensation (Compensation).