We’ve identified an issue with our Payroll hub service

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted 17 days ago. Mar 16, 2025 - 02:25 IST

Identified

We confirm there is a problem with our Payroll hub service and we’re working to resolve it.
Posted 17 days ago. Mar 16, 2025 - 02:08 IST
This incident affected: Payroll hub (Payroll Hub).