Talent service - Performance and Surveys aren't loading

Incident Report for HiBob

Resolved

The issue affecting the Talent module has been resolved. An infrastructure issue caused increased latency that impacted Surveys and Performance. The service has remained stable after implementing a fix, and we are taking measures to prevent recurrence.
Posted Aug 26, 2026 - 11:38 IDT

Monitoring

A fix has been applied to address the issues affecting Performance and Surveys in the Talent module, and we’re monitoring the results.
Posted Aug 26, 2026 - 10:52 IDT

Identified

We confirm there is a problem with our Talent service, affecting Performance and Surveys, and we’re working to resolve it.
Posted Aug 26, 2026 - 10:34 IDT

Investigating

We are investigating an issue with our Talent service impacting Surveys and Performance. We’re working to resolve it.
Posted Aug 26, 2026 - 10:29 IDT
This incident affected: Talent (Surveys, Performance).