We’ve identified an issue with our Talent service

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted Sep 22, 2023 - 04:01 IDT

Identified

We confirm there is a problem with our Talent service, and we’re working to resolve it.
Posted Sep 22, 2023 - 04:00 IDT
This incident affected: Talent (Surveys).