We’ve identified an issue with our Payroll hub service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Jan 09, 2025 - 07:13 IST
Identified
We confirm there is a problem with our Payroll hub service and we’re working to resolve it.
Posted Jan 09, 2025 - 07:03 IST
This incident affected: Payroll hub (Payroll Hub).