Delay in Sandbox refresh

Incident Report for HiBob

Resolved

The issue has been resolved.
Posted Jul 03, 2026 - 09:42 IDT

Identified

We are currently experiencing delays with our Sandbox Refresh service.
The issue has been addressed, and the service is gradually returning to normal. We apologize for the inconvenience and appreciate your patience.
Posted Jul 02, 2026 - 22:14 IDT
This incident affected: Sandbox (Sandbox).