We’ve identified an issue with our Hiring module.

Incident Report for HiBob

Resolved

The issue affecting parts of our Hiring module has been resolved. Affected features are now available again.
We apologize for the inconvenience and thank you for your understanding.
Posted Jun 15, 2026 - 13:32 IDT

Identified

We’ve identified issues affecting parts of our Hiring module. Some features may be temporarily unavailable while we work to resolve the issue. We’ll continue to provide updates as more information becomes available.
We apologize for the inconvenience and thank you for your understanding.
Posted Jun 15, 2026 - 13:08 IDT
This incident affected: Hiring (Core, Public pages).