We’ve identified an issue with our Email service

Incident Report for HiBob

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 17:13 IST

Investigating

We are currently investigating this issue.
Posted Feb 03, 2025 - 15:55 IST