We’ve identified an issue with our Payroll hub service

Incident Report for HiBob

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 15:53 IST

Identified

We confirm there is a problem with our Payroll hub service and we’re working to resolve it.
Posted Feb 03, 2025 - 15:02 IST
This incident affected: Payroll hub (Payroll Hub).