We’ve identified an issue with our Sandbox service

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted May 23, 2023 - 11:10 IDT

Identified

We confirm there is a problem with our Sandbox service, and we’re working to resolve it.
Posted May 23, 2023 - 11:00 IDT
This incident affected: Sandbox (Sandbox).