We’ve identified an issue with our email service

Incident Report for HiBob

Resolved

The issue has been resolved, and all services are now operating normally.
The email delivery delays were caused by a system issue that led to an unexpected spike in outbound email volume.
We apologise for the inconvenience and thank you for your patience.
Posted Jan 29, 2026 - 16:21 IST

Monitoring

The root cause has been identified, and email delivery is improving. A backlog of emails is still pending, and we’re monitoring closely as the sending rate continues to recover.
Thank you for your patience.
Posted Jan 29, 2026 - 15:37 IST

Identified

We are currently experiencing a delay in email delivery.
This may impact several workflows.
Users logging in with MFA may experience delays receiving authentication emails.
Our team is working to resolve this as quickly as possible.
Posted Jan 29, 2026 - 13:32 IST
This incident affected: Compensation (Compensation), Talent (Surveys, Performance, Goals), Payroll (Payroll Hub, US Payroll & Ben Admin, UK Payroll), Public API (Public API), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Sandbox (Sandbox), Time (Time Off, Time & Attendance), Your Voice (Your Voice), Learning (Learning), Mobile (Mobile), Core HR (Shoutout, Docs, Job catalog, Employee Profile and Fields, Reports and Directory, Tasks, Flows), and Hiring (Core, Public pages).