We’ve identified an issue with our Docs service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Feb 04, 2025 - 13:23 IST
Identified
We confirm there is a problem with our Docs service, and we’re working to resolve it.
Posted Feb 04, 2025 - 13:20 IST
This incident affected: Core HR (Docs).