We’ve identified an issue with our Hiring Core (ATS,Settings) service
Incident Report for HiBob
Resolved
We confirm there is a problem with our Hiring service, and we’re working to resolve it.
Posted Nov 17, 2024 - 14:43 IST
Investigating
We confirm there is a problem with our Hiring service, and we’re working to resolve it.
Posted Nov 17, 2024 - 14:39 IST
This incident affected: Hiring (Core).