Investigating Performance Degradation in HiBob Application

Incident Report for HiBob

Resolved

We identified a performance degradation in the HiBob application caused by resource contention and long-running database operations; mitigation actions were applied and the service has stabilized. We apologize for the disruption and thank you for your patience.
Posted Mar 23, 2026 - 11:27 IST

Update

We are continuing to monitor for any further issues.
Posted Mar 23, 2026 - 11:20 IST

Update

We are continuing to monitor for any further issues.
Posted Mar 23, 2026 - 11:12 IST

Monitoring

The service is in the process of recovering, and we are continuing to monitor closely while investigating the root cause. We apologize for the disruption and thank you for your patience.
Posted Mar 23, 2026 - 11:01 IST

Identified

The service is in the process of recovering, and we are continuing to monitor closely while investigating the root cause. We apologize for the disruption and thank you for your patience.
Posted Mar 23, 2026 - 11:01 IST

Update

We are currently experiencing elevated error rates and latency due to database query timeouts affecting the HiBob service, and are actively working to resolve the issue. We apologize for the disruption and thank you for your patience.
Posted Mar 23, 2026 - 10:52 IST

Investigating

We confirm there is a problem with our main HiBob application, and we’re working to resolve it.
Posted Mar 23, 2026 - 10:27 IST
This incident affected: Compensation (Compensation), Talent (Surveys), Payroll (Payroll Hub), Public API (Public API), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Core HR (Shoutout, Docs, Job catalog), and Time (Time & Attendance).