Hiring Module Accessibility Issue Identified

Incident Report for HiBob

Resolved

The issue has been resolved after reverting a recent performance optimization change that unintentionally introduced errors. We apologize for the disruption and thank you for your patience.
Posted Aug 27, 2025 - 18:18 IDT

Update

We have identified the root cause and are working on a fix.
Posted Aug 27, 2025 - 17:55 IDT

Identified

We are currently investigating the issue. Thank you for your patience
Posted Aug 27, 2025 - 15:49 IDT
This incident affected: Hiring (Core, Public pages).