We’ve monitored the platform closely over the past few hours and are seeing consistent stability across all systems.
Our teams continue to investigate and are actively working on improvements to further strengthen resilience and long-term stability.
We sincerely apologize for the disruption and thank you for your continued trust and patience. — The HiBob Engineering Team
Posted Jul 22, 2025 - 17:37 IDT
Monitoring
We’ve been experiencing intermittent issues with our database connectivity, which may have caused intermittent slowness or temporary errors for some users.
Current Status: System performance has significantly improved and is largely stable. We’ve taken a number of mitigation steps to improve connection availability, and the issue is no longer actively impacting services. That said, our engineering teams are continuing to investigate the root cause to ensure a complete resolution.
What we know so far: Our systems experienced a spike in usage of database connections, reaching the maximum limit. While the database itself was healthy, some connections remained open longer than expected. This behavior limited the availability of connections for incoming requests. We’ve applied changes to reduce load and increase resiliency, which have helped stabilize the environment.
Next Steps: Our task force is working across multiple services to pinpoint the exact behavior or recent changes that may have contributed to the connection exhaustion. We’re monitoring all systems closely and will share additional information once we complete the investigation.
What you can expect: • Most services are currently performing normally, though users may still experience occasional issues • No action is required on your part. • We’ll continue to keep you informed as we learn more.
Thank you for your continued trust and patience. — The HiBob Engineering Team
Posted Jul 22, 2025 - 14:02 IDT
Investigating
We are continuing to experience intermittent instability in the HiBob application. All relevant teams are actively engaged in a cross-system investigation to identify the root cause and implement a resolution as quickly as possible. This remains a top priority, and we appreciate your patience as we work to restore full service reliability.
Posted Jul 22, 2025 - 11:48 IDT
Monitoring
The HiBob application is currently stable following a series of mitigations. Today’s disruption was caused by an unfortunate combination of overlapping issues — including a third-party integration change, a spike in system load, and a recent code update that introduced a bottleneck. We’ve rolled back the code change, reverted the integration update, and cleared the system backlog. Although it’s uncommon for these kinds of issues to occur at the same time, we’re monitoring the platform closely and conducting a deeper investigation into the root cause to help prevent similar incidents in the future. Thank you for your patience and understanding.
Posted Jul 21, 2025 - 20:08 IDT
Identified
We’re currently investigating intermittent slowness and availability issues affecting the HiBob application. Our team is also assessing potential links to earlier incidents. We’ll provide updates as soon as more information becomes available. We apologize for the disruption and appreciate your patience.
Posted Jul 21, 2025 - 13:31 IDT
Monitoring
We’re currently investigating intermittent slowness and availability issues affecting the HiBob application.
Posted Jul 21, 2025 - 13:30 IDT
This incident affected: Compensation (Compensation), Talent (Surveys, Performance, Goals), Payroll hub (Payroll Hub), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Time (Time Off, Time & Attendance), Your Voice (Your Voice), Learning (Learning), Core HR (Shoutout, Docs, Job catalog, Employee Profile and Fields, Reports and Directory, Tasks, Flows), and Hiring (Core, Public pages).