We’ve identified an issue with our main HiBob application

Incident Report for HiBob

Resolved

We’ve identified and resolved the issue.
Posted Jul 21, 2025 - 13:03 IDT

Investigating

We’re currently experiencing issues with the HiBob application shortly after resolving a previous incident.
Our team is investigating and checking whether this is related to the earlier issue.
We apologize for the renewed disruption and will share more information as soon as possible. Thank you for your continued patience.
Posted Jul 21, 2025 - 12:56 IDT

Identified

We confirm there is a problem with our main HiBob application, and we’re working to resolve it.
Posted Jul 21, 2025 - 12:35 IDT
This incident affected: Compensation (Compensation), Talent (Surveys), Payroll hub (Payroll Hub), Public API (Public API), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Core HR (Shoutout, Docs, Job catalog), and Time (Time & Attendance).