We’ve identified an issue with our Bob platform

Incident Report for HiBob

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 14:37 IDT

Monitoring

We’ve applied mitigations and are now seeing improved performance across the HiBob platform. The issue was caused by an internal background process that became overloaded due to a spike in activity from one or more tenants. This increase triggered a higher frequency of backend operations, which overwhelmed shared system components and led to performance degradation.

We’re continuing to monitor closely to ensure full stability. Thank you for your patience and understanding.
Posted Jul 31, 2025 - 13:26 IDT

Identified

We've identified the source of the current issue, have taken first mitigation steps and are working to fully stabilize the platform. We'll share further updates as we make progress.

Thanks again for your patience.
Posted Jul 31, 2025 - 13:00 IDT

Update

We are continuing to investigate this issue.
Posted Jul 31, 2025 - 12:38 IDT

Investigating

We’re currently experiencing slowness and intermittent errors across the HiBob platform. Our engineering teams are actively investigating the issue to identify the root cause and restore full service as quickly as possible.

We understand how disruptive this is and apologize for the impact. We’ll continue to provide updates as we learn more.
Posted Jul 31, 2025 - 12:11 IDT
This incident affected: Compensation (Compensation), Talent (Surveys, Performance, Goals), Payroll hub (Payroll Hub), Public API (Public API), Workforce planning (Workforce planning), Time (Time Off, Time & Attendance), Your Voice (Your Voice), Learning (Learning), Core HR (Shoutout, Docs, Job catalog, Employee Profile and Fields, Reports and Directory, Tasks, Flows), and Hiring (Core, Public pages).