We’ve identified an issue with our Workflows service
Incident Report for HiBob
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 13:16 IDT
Identified
We confirm there is an issue with the Self-service workflows, and we’re working to resolve it.
Posted Jul 16, 2024 - 11:58 IDT
This incident affected: Core HR (Flows).