We’ve identified an issue with our Sandbox environment

Incident Report for HiBob

Resolved

Some customers experienced errors and timeouts in our Sandbox environment.
Root cause: A change intended to upgrade our network communication and monitoring introduced a protocol incompatibility between services, which disrupted inter-service communication.
Fix: We quickly rolled back the change, and Sandbox has been stable since.
Scope: Impact was limited to Sandbox; we have no evidence of impact to production environments.
We’re improving our rollout safeguards by adding protocol-compatibility tests, staged/canary deployments, and tighter monitoring to prevent a recurrence.
Posted Aug 21, 2025 - 11:34 IDT

Update

We are continuing to monitor for any further issues.
Posted Aug 21, 2025 - 11:16 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2025 - 11:11 IDT

Investigating

We are currently investigating an issue causing errors when accessing the Sandbox environment.
Posted Aug 21, 2025 - 09:52 IDT
This incident affected: Sandbox (Sandbox).