We’ve identified an issue with our Payroll hub service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Oct 10, 2024 - 17:06 IDT
Identified
We confirm there is a problem with our Payroll hub service and we’re working to resolve it.
Posted Oct 10, 2024 - 16:18 IDT
This incident affected: Payroll hub (Payroll Hub).