We’ve identified an issue with our Docs service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Jan 06, 2025 - 15:56 IST
Identified
We confirm there is a problem with our Docs service, and we’re working to resolve it.
Posted Jan 06, 2025 - 15:53 IST
This incident affected: Core HR (Docs).