We’ve identified an issue with our main HiBob application

Incident Report for HiBob

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 13:34 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 13:23 IST

Update

We are currently running a database vacuum process to optimize performance following the rollback. This process helps reclaim storage, refresh database statistics, and improve overall query performance after the earlier maintenance and restart activities.

At this time, system performance is stable, and the platform is operating normally across all core services. We are not observing any ongoing impact on customer workflows.

Our engineering team continues to closely monitor the environment, reviewing performance metrics and system health indicators to ensure sustained stability and proactively address any anomalies that arise.
Posted Feb 23, 2026 - 13:20 IST

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 13:00 IST

Update

The rollback has been successfully completed, and the platform is up.

However, we are still experiencing performance degradation in certain areas, and some users may encounter slowness. Our engineering team is actively investigating and working to fully restore system performance.

We will continue to provide updates as we make progress.
Posted Feb 23, 2026 - 12:10 IST

Identified

We are currently investigating a production issue that may be related to a database maintenance activity performed on Saturday during off-hours.

As part of our mitigation efforts, we are reverting the recent change. This action will require restarting the production database, which may result in a brief service disruption of a few minutes.

We will provide an additional update once the restart is complete and the system is fully stabilized.

Thank you for your patience.
Posted Feb 23, 2026 - 11:40 IST

Investigating

We confirm there is a problem with our main HiBob application and we’re working to resolve it.
Posted Feb 23, 2026 - 10:54 IST
This incident affected: Compensation (Compensation), Talent (Surveys, Performance, Goals), Payroll (Payroll Hub, US Payroll & Ben Admin, UK Payroll), Public API (Public API), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Sandbox (Sandbox), Time (Time Off, Time & Attendance), Your Voice (Your Voice), Learning (Learning), Mobile (Mobile), Core HR (Shoutout, Docs, Job catalog, Employee Profile and Fields, Reports and Directory, Tasks, Flows), and Hiring (Core, Public pages).