Some users may experience slower-than-usual performance at the moment. Our team is aware of the issue and is actively working to identify the root cause and resolve it. We appreciate your patience and will share updates as we make progress.
The issue that we had been experiencing has now been fully resolved, and everything is functioning as expected. After identifying the root cause and implementing the necessary fixes, we can confirm that the situation is under control and no further action is required at this time.
Posted Apr 07, 2026 - 19:00 IDT
Monitoring
System performance has been restored, and the incident is now resolved.
We are continuing to monitor the system and conduct a thorough investigation to identify the root cause and implement preventive measures. Thank you for your patience during this time.
Posted Apr 07, 2026 - 18:52 IDT
Investigating
We confirm there is a problem with our main HiBob application, and we’re working to resolve it.
Posted Apr 07, 2026 - 17:56 IDT
This incident affected: Compensation (Compensation), Talent (Surveys, Performance, Goals), Workforce planning (Workforce planning), Sandbox (Sandbox), Time (Time Off, Time & Attendance), Your Voice (Your Voice), Learning (Learning), Mobile (Mobile), Core HR (Shoutout, Docs, Job catalog, Employee Profile and Fields, Reports and Directory, Tasks, Flows), and Hiring (Core, Public pages).