We’ve identified an issue with our Payroll hub service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Nov 13, 2024 - 05:48 IST
Identified
We confirm there is a problem with our Payroll hub service and we’re working to resolve it.
Posted Nov 13, 2024 - 05:39 IST
This incident affected: Payroll hub (Payroll Hub).