The issue affecting the HiBob application has now been resolved. It was caused by a performance bottleneck in our database, which led to increased latency. We sincerely apologize for the disruption and thank you for your patience while we worked to restore normal service.
Posted Jul 21, 2025 - 11:44 IDT
Update
We’ve made progress in identifying the root cause of the issue impacting the main HiBob application and are working on a fix. Some functionality is gradually recovering. Further updates will follow shortly.
Posted Jul 21, 2025 - 11:26 IDT
Identified
We confirm there is a problem with our main HiBob application, and we’re working to resolve it.
Posted Jul 21, 2025 - 10:19 IDT
This incident affected: Compensation (Compensation), Talent (Surveys), Payroll hub (Payroll Hub), Public API (Public API), Integrations (Zapier, Calendar integration, Provisioning, Collaboration), Workforce planning (Workforce planning), Core HR (Shoutout, Docs, Job catalog), and Time (Time & Attendance).