We’ve identified an issue with our Docs service
Incident Report for HiBob
Resolved
We’ve identified and resolved the issue.
Posted Oct 14, 2024 - 14:55 IDT
Identified
We confirm there is a problem with our Docs service, and we’re working to resolve it.
Posted Oct 14, 2024 - 14:51 IDT
This incident affected: Core HR (Docs).